rotate90Around Method
Rotate this vector 90 degrees around an axis vector.
rotate90Around(axis: Vector3d, result?: Vector3d): undefined | Vector3d
@returns the (new or optionally reused result) rotated vector, or undefined if the axis vector cannot be normalized.
Parameter | Type | Description |
---|---|---|
axis | Vector3d | |
result | Vector3d |
Returns - undefined | Vector3d
the (new or optionally reused result) rotated vector, or undefined if the axis vector cannot be normalized.
Defined in
- geometry3d/Point3dVector3d.ts Line 1106
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.