radiansFromPerpendicular Method
Return the angle in radians (not as strongly typed Angle) from this vector to the plane perpendicular to planeNormal.
- The returned angle is between -PI/2 and PI/2.
- The returned angle is measured in the plane containing the two vectors.
- The function returns PI/2 - radiansTo(planeNormal).
radiansFromPerpendicular(planeNormal: Vector3d): number
Parameter | Type | Description |
---|---|---|
planeNormal | Vector3d | a normal vector to the plane. |
Returns - number
Defined in
- geometry3d/Point3dVector3d.ts Line 1479
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.