isParallelTo Method
Test if this vector is parallel to other.
- The input tolerances in
options
, if given, are considered to be squared for efficiency's sake, so if you have a distance or angle tolerance t, you should pass in t * t.
isParallelTo(other: Vector3d, oppositeIsParallel: booleanfalse, returnValueIfAnInputIsZeroLength: booleanfalse, options?: PerpParallelOptions): boolean
Parameter | Type | Description |
---|---|---|
other | Vector3d | second vector in comparison |
oppositeIsParallel | boolean | whether to consider diametrically opposed vectors as parallel |
returnValueIfAnInputIsZeroLength | boolean | if either vector is near zero length, return this value. |
options | PerpParallelOptions | optional radian and distance tolerances. |
Returns - boolean
Defined in
- geometry3d/Point3dVector3d.ts Line 1580
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.