interpolate Method
Return a vector computed at fractional position between this vector and vectorB.
interpolate(fraction: number, vectorB: Readonly<WritableXYAndZ>, result?: Vector3d): Vector3d
Parameter | Type | Description |
---|---|---|
fraction | number | fractional position. 0 is at this . 1 is at vectorB . True fractions are "between",negatives are "before this", beyond 1 is "beyond vectorB". |
vectorB | Readonly<WritableXYAndZ> | second vector. |
result | Vector3d | optional preallocated result. |
Returns - Vector3d
Defined in
- geometry3d/Point3dVector3d.ts Line 1120
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.