createNormalizedStartEnd MethodStatic
Create a normalized vector from startPoint to endPoint
createNormalizedStartEnd(startPoint: Readonly<WritableXYAndZ>, endPoint: Readonly<WritableXYAndZ>, result?: Vector3d): undefined | Vector3d
@returns undefined if and only if normalization fails.
Parameter | Type | Description |
---|---|---|
startPoint | Readonly<WritableXYAndZ> | start point of vector |
endPoint | Readonly<WritableXYAndZ> | end point of vector |
result | Vector3d | optional result |
Returns - undefined | Vector3d
undefined if and only if normalization fails.
Defined in
- geometry3d/Point3dVector3d.ts Line 990
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.