setFromJSON Method
Set this Transform instance from flexible inputs:
- Any object (such as another Transform or TransformProps) that has
origin
andmatrix
members accepted byPoint3d.setFromJSON
andMatrix3d.setFromJSON
- An array of 3 number arrays, each with 4 entries which are rows in a 3x4 matrix.
- An array of 12 numbers, each block of 4 entries as a row 3x4 matrix.
- If no input is provided, the identity Transform is returned.
setFromJSON(json?: TransformProps | Transform): void
Parameter | Type | Description |
---|---|---|
json | TransformProps | Transform |
Returns - void
Defined in
- geometry3d/Transform.ts Line 79
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.