multiplyXYZWToFloat64Array Method
Transform the homogeneous point. Return as new Float64Array
with size 4, or in the pre-allocated result
of sufficient size.
- If
p = (x,y,z)
then this method computesTp = M*p + o*w
and returns theFloat64Array
formed byTp
in the first 3 numbers of the array andw
as the fourth. - Logically, this is multiplication by the 4x4 matrix formed from the 3x4 instance augmented with fourth row 0001.
multiplyXYZWToFloat64Array(x: number, y: number, z: number, w: number, result?: Float64Array): Float64Array
Parameter | Type | Description |
---|---|---|
x | number | |
y | number | |
z | number | |
w | number | |
result | Float64Array |
Returns - Float64Array
Defined in
- geometry3d/Transform.ts Line 442
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.