multiplyXYZW Method
Transform the homogeneous point. Return as a new Point4d
, or in the pre-allocated result (if result is given).
- If
p = (x,y,z)
then this method computesTp = M*p + o*w
and returns thePoint4d
formed byTp
in the first three coordinates, andw
in the fourth. - Logically, this is multiplication by the 4x4 matrix formed from the 3x4 instance augmented with fourth row 0001.
multiplyXYZW(x: number, y: number, z: number, w: number, result?: Point4d): Point4d
Parameter | Type | Description |
---|---|---|
x | number | |
y | number | |
z | number | |
w | number | |
result | Point4d |
Returns - Point4d
Defined in
- geometry3d/Transform.ts Line 433
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.