multiplyRange Method
Return the range of the transformed corners.
- The 8 corners are transformed individually.
- Note: Suppose you have a geometry, a range box around that geometry, and your Transform is a rotation.
If you rotate the range box and recompute a new range box around the rotated range box, then the new range
box will have a larger volume than the original range box. However, if you rotate the geometry itself and
then recompute the range box, it will be a tighter range box around the rotated geometry.
multiplyRange
function creates the larger range box because it only has access to the range box and not the geometry itself.
multiplyRange(range: Range3d, result?: Range3d): Range3d
Parameter | Type | Description |
---|---|---|
range | Range3d | |
result | Range3d |
Returns - Range3d
Defined in
- geometry3d/Transform.ts Line 747
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.