multiplyInversePoint4d Method
Multiply the homogenous point by the inverse Transform.
- If for a point
p
we haveTp = M*p + o = q
, thenp = MInverse*(q - o) = TInverse q
soTInverse
Transform has matrix partMInverse
and origin part-MInverse*o
. - This method computes
TInverse p = MInverse*p - w*MInverse*o
and returns thePoint4d
formed byTInverse*p
in the first three coordinates, andw
in the fourth. - Logically, this is multiplication by the inverse of the 4x4 matrix formed from the 3x4 instance augmented with fourth row 0001. This is equivalent to the 4x4 matrix formed in similar fashion from the inverse of this instance.
- Return as a new point or in the optional
result
. - Returns
undefined
if thematrix
part if this Transform is singular.
multiplyInversePoint4d(weightedPoint: Point4d, result?: Point4d): undefined | Point4d
Parameter | Type | Description |
---|---|---|
weightedPoint | Point4d | |
result | Point4d |
Returns - undefined | Point4d
Defined in
- geometry3d/Transform.ts Line 508
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.