multiplyInversePoint3dArray Method
Multiply each point in the array by the inverse of this
Transform.
- For a transform
T = [M o]
the inverse transformT' = [M' -M'o]
exists if and only ifM
has an inverseM'
. Indeed, for any pointp
, we haveT'Tp = T'(Mp + o) = M'(Mp + o) - M'o = M'Mp + M'o - M'o = p.
- If
result
is given, resize it to match the inputpoints
array and update it with original pointsp[]
. - If
result
is not given, return a new array. - Returns
undefined
if thematrix
part if this Transform is singular.
multiplyInversePoint3dArray(points: Point3d[], result?: Point3d[]): undefined | Point3d[]
Parameter | Type | Description |
---|---|---|
points | Point3d[] | |
result | Point3d[] |
Returns - undefined | Point3d[]
Defined in
- geometry3d/Transform.ts Line 571
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.