multiplyInversePoint3d Method
Multiply the point by the inverse Transform.
- If for a point
p
we haveTp = M*p + o = q
, thenp = MInverse*(q - o) = TInverse q
soTInverse
Transform has matrix partMInverse
and origin part-MInverse*o
. - Return as a new point or in the optional
result
. - Returns
undefined
if thematrix
part if this Transform is singular.
multiplyInversePoint3d(point: Readonly<WritableXYAndZ>, result?: Point3d): undefined | Point3d
Parameter | Type | Description |
---|---|---|
point | Readonly<WritableXYAndZ> | |
result | Point3d |
Returns - undefined | Point3d
Defined in
- geometry3d/Transform.ts Line 489
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.