matchArrayLengths MethodStatic
Match the length of destination array with the length of source array
- If destination has more elements than source, remove the extra elements.
- If destination has fewer elements than source, use
constructionFunction
to create new elements.
matchArrayLengths(source: any[], dest: any[], constructionFunction: () => any): number
Parameter | Type | Description |
---|---|---|
source | any[] | the source array |
dest | any[] | the destination array |
constructionFunction | () => any | function to call to create new elements. |
Returns - number
Defined in
- geometry3d/Transform.ts Line 551
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.