initFromRange MethodStatic
Initialize 2 Transforms that map between the unit box (specified by 000 and 111) and the range box specified by the input points.
initFromRange(min: Point3d, max: Point3d, npcToGlobal?: Transform, globalToNpc?: Transform): void
Parameter | Type | Description |
---|---|---|
min | Point3d | the min corner of the range box |
max | Point3d | the max corner of the range box |
npcToGlobal | Transform | maps NPC coordinates into range box coordinates. Specifically, maps 000 to min and maps111 to max . This Transform is the inverse of globalToNpc . Object created by caller, re-initialized here. |
globalToNpc | Transform | maps range box coordinates into NPC coordinates. Specifically, maps min to 000 and mapsmax to 111. This Transform is the inverse of npcToGlobal . Object created by caller, re-initialized here.* NPC stands for Normalized Projection Coordinate |
Returns - void
Defined in
- geometry3d/Transform.ts Line 797
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.