createTranslationXYZ MethodStatic
Create a Transform with translation provided by x,y,z parts.
- Translation Transform maps any vector
v
tov + p
wherep = (x,y,z)
- Visualization can be found at https://www.itwinjs.org/sandbox/SaeedTorabi/CubeTransform
createTranslationXYZ(x: number0, y: number0, z: number0, result?: Transform): Transform
@returns new or updated transform
Parameter | Type | Description |
---|---|---|
x | number | x part of translation |
y | number | y part of translation |
z | number | z part of translation |
result | Transform | optional pre-allocated Transform |
Returns - Transform
new or updated transform
Defined in
- geometry3d/Transform.ts Line 211
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.