createScaleAboutPoint MethodStatic
Create a Transform which leaves the fixedPoint unchanged and scales everything else around it by
a single scale factor. The returned Transform maps a point p
to M*p + (f - M*f)
where f
is the fixedPoint and M is the scale matrix (i.e., Tp = M*(p-f) + f
).
- Visualization can be found at https://www.itwinjs.org/sandbox/SaeedTorabi/CubeTransform
createScaleAboutPoint(fixedPoint: Point3d, scale: number, result?: Transform): Transform
Parameter | Type | Description |
---|---|---|
fixedPoint | Point3d | |
scale | number | |
result | Transform |
Returns - Transform
Defined in
- geometry3d/Transform.ts Line 358
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.