createOriginAndMatrix MethodStatic
Create a Transform using the given origin
and matrix
.
- This is the appropriate construction when the columns of the matrix are coordinate axes of a local-to-world mapping, and the given point is the axes' origin in world coordinates.
- This function is closely related to
createFixedPointAndMatrix
whose point input is the fixed point of the world-to-world transformation. - If origin is
undefined
, (0,0,0) is used. If matrix isundefined
the identity matrix is used.
createOriginAndMatrix(origin: XYZ, matrix: Matrix3d, result?: Transform): Transform
Parameter | Type | Description |
---|---|---|
origin | XYZ | |
matrix | Matrix3d | |
result | Transform |
Returns - Transform
Defined in
- geometry3d/Transform.ts Line 266
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.