createMatrixPickupPutdown MethodStatic
Create a transform with the specified matrix
and points a
and b
. The returned Transform maps
point p
to M*(p-a) + b
(i.e., Tp = M*(p-a) + b
), so maps a
to b
.
createMatrixPickupPutdown(matrix: Matrix3d, a: Point3d, b: Point3d, result?: Transform): Transform
Parameter | Type | Description |
---|---|---|
matrix | Matrix3d | |
a | Point3d | |
b | Point3d | |
result | Transform |
Returns - Transform
Defined in
- geometry3d/Transform.ts Line 345
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.