createFlattenAlongVectorToPlane MethodStatic
Return a transformation which flattens space onto a plane, sweeping along a direction which may be different from the plane normal.
- See [Matrix3d.createFlattenAlongVectorToPlane] for math details.
createFlattenAlongVectorToPlane(sweepVector: Vector3d, planePoint: Readonly<WritableXYAndZ>, planeNormal: Vector3d): undefined | Transform
Parameter | Type | Description |
---|---|---|
sweepVector | Vector3d | sweep direction. If same as planeNormal , the resulting transformation flattens to the plane. |
planePoint | Readonly<WritableXYAndZ> | any point on the plane |
planeNormal | Vector3d | vector normal to the plane. |
Returns - undefined | Transform
Defined in
- geometry3d/Transform.ts Line 375
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.