createFixedPointAndMatrix MethodStatic
Create a Transform with the specified matrix
. Compute an origin
(different from the given fixedPoint
)
so that the fixedPoint
maps back to itself. The returned Transform, transforms a point p
to M*p + (f - M*f)
where f
is the fixedPoint (i.e., Tp = M*(p-f) + f
).
createFixedPointAndMatrix(fixedPoint: Readonly<WritableXYAndZ>, matrix: Matrix3d, result?: Transform): Transform
Parameter | Type | Description |
---|---|---|
fixedPoint | Readonly<WritableXYAndZ> | |
matrix | Matrix3d | |
result | Transform |
Returns - Transform
Defined in
- geometry3d/Transform.ts Line 328
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.