perpendicularPartOfVectorToTarget Method
Return the shortest vector v
to targetPoint
from the line defined by this ray.
- If the projection of
targetPoint
onto the line defined by this ray is q, thenv = targetPoint - q
.
perpendicularPartOfVectorToTarget(targetPoint: Readonly<WritableXYAndZ>, result?: Vector3d): Vector3d
Parameter | Type | Description |
---|---|---|
targetPoint | Readonly<WritableXYAndZ> | |
result | Vector3d |
Returns - Vector3d
Defined in
- geometry3d/Ray3d.ts Line 483
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.