intersectionWithRange3d Method
Find the intersection of the line defined by the ray with a Range3d.
- Return the range of parameters (on the ray) which are "inside" the range.
- Note that a range is always returned; if there is no intersection it is indicated by the test
result.isNull
.
intersectionWithRange3d(range: Range3d, result?: Range1d): Range1d
Parameter | Type | Description |
---|---|---|
range | Range3d | |
result | Range1d |
Returns - Range1d
Defined in
- geometry3d/Ray3d.ts Line 372
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.