dotProductToPoint Method
Return the dot product of the ray's direction vector with a vector from the ray origin
to the spacePoint
.
- If the instance is the unit normal of a plane, then this method returns the (signed) altitude
of
spacePoint
with respect to the plane. - Visualization can be found at https://www.itwinjs.org/sandbox/SaeedTorabi/ProjectVectorOnPlane
dotProductToPoint(spacePoint: Point3d): number
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d |
Returns - number
Defined in
- geometry3d/Ray3d.ts Line 87
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.