unpackFloat64ArrayToPointsAndWeights MethodStatic
Unpack packed 4D data to a Point3d array and an array of weights.
WeightStyle
ofdata
is not assumed. If input data is of form [a,b,c,d], default output arrays will have form [a,b,c] and [d].
unpackFloat64ArrayToPointsAndWeights(data: Float64Array, points: Point3d[], weights: number[], pointFormatter: (x: number, y: number, z: number) => any...): void
Parameter | Type | Description |
---|---|---|
data | Float64Array | input 4D points (packed) |
points | Point3d[] | output 3D data |
weights | number[] | output weights (w portion of input) |
pointFormatter | (x: number, y: number, z: number) => any | optional xyz formatter. By default, returns a Point3d created from the xyz portion of the input. |
Returns - void
Defined in
- geometry3d/PointHelpers.ts Line 464
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.