packPointsAndWeightsToFloat64Array MethodStatic
Copy each weighted point and its corresponding weight into a packed buffer.
packPointsAndWeightsToFloat64Array(data: Float64Array | number[] | Point3d[], weights: Float64Array | number[], result?: Float64Array): undefined | Float64Array
@returns packed weighted point array
Parameter | Type | Description |
---|---|---|
data | Float64Array | number[] | Point3d[] | array of weighted xyz |
weights | Float64Array | number[] | scalar weight array |
result | Float64Array | optional destination array. If insufficiently sized, a new array is returned. |
Returns - undefined | Float64Array
packed weighted point array
Defined in
- geometry3d/PointHelpers.ts Line 395
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.