convexPolygonClipInPlace MethodStatic
Clip a polygon, returning the clip result in the same object.
convexPolygonClipInPlace(plane: PlaneAltitudeEvaluator, xyz: Point3d[], work: Point3d[], tolerance: numberGeometry.smallMetricDistance): void
Parameter | Type | Description |
---|---|---|
plane | PlaneAltitudeEvaluator | |
xyz | Point3d[] | input/output polygon |
work | Point3d[] | scratch object |
tolerance | number | tolerance for on-plane decision. |
Returns - void
Defined in
- geometry3d/PolygonOps.ts Line 1662
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.