computeConvexHullXY MethodStatic

Computes the hull of the XY projection of points.

computeConvexHullXY(points: Point3d[], hullPoints: Point3d[], insidePoints: Point3d[], addClosurePoint: booleanfalse): void

Parameter Type Description
points Point3d[] input points, z-coordinates ignored.
hullPoints Point3d[] (output) points on the convex hull (cloned from input points).
insidePoints Point3d[] (output) points not on the convex hull (cloned from input points).
addClosurePoint boolean whether to append the first hull point to hullPoints.

Returns - void

Defined in

Last Updated: 21 November, 2024