createFromPackedXYZW MethodStatic
Copy and unweight xyzw.
createFromPackedXYZW(xyzwData: Float64Array, pointIndex: number, result?: Point3d): undefined | Point3d
@returns unweighted xyz
Parameter | Type | Description |
---|---|---|
xyzwData | Float64Array | flat array of weighted homogeneous points: xw,yw,zw,w |
pointIndex | number | index of point to extract. This index is multiplied by 4 to obtain starting index in the array. |
result | Point3d | optional result point. |
Returns - undefined | Point3d
unweighted xyz
Defined in
- geometry3d/Point3dVector3d.ts Line 483
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.