searchStrictlyIncreasingNumbers MethodStatic
Given an array of strictly increasing numbers, find the index of the largest number that is less than or equal
to value
.
- Get an initial estimate by proportions of
value
and the first and last entries. - Linear search from there for final value.
- For regularly spaced numbers (e.g.,
data
is the_facetStart
indices for a triangulated IndexedPolyface), the proportional estimate will be immediately correct.
searchStrictlyIncreasingNumbers(data: ReadonlyArray
Parameter | Type | Description |
---|---|---|
data | ReadonlyArray |
the array of strictly increasing numbers |
value | number | the value to search for |
Returns - undefined | number
Defined in
- geometry3d/PointHelpers.ts Line 321
Last Updated: 04 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.