isAlmostEqualAllowZRotation Method
A matrix equivalence test, returning true if and only if the matrices are almost equal, or all of the following column comparisons hold:
- z columns are almost equal, and
- x columns differ only by a rotation of angle t around the z column, and
- y columns differ only by a rotation of the same angle t around the z column.
isAlmostEqualAllowZRotation(other: Matrix3d, tol?: number): boolean
@returns whether matrices are almost equal modulo a rotation around their common nonzero z-column.
Parameter | Type | Description |
---|---|---|
other | Matrix3d | matrix to compare |
tol | number | optional distance tolerance, for comparisons by Geometry.isDistanceWithinTol |
Returns - boolean
whether matrices are almost equal modulo a rotation around their common nonzero z-column.
Defined in
- geometry3d/Matrix3d.ts Line 371
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.