createFromQuaternion MethodStatic
Create a matrix from a quaternion. WARNING: There is frequent confusion over whether a "from quaternion" matrix is organized by rows or columns. If you find that the matrix seems to rotate by the opposite angle, transpose it.
Some math details can be found at http://marc-b-reynolds.github.io/quaternions/2017/08/08/QuatRotMatrix.html
createFromQuaternion(quat: Point4d): Matrix3d
Parameter | Type | Description |
---|---|---|
quat | Point4d |
Returns - Matrix3d
Defined in
- geometry3d/Matrix3d.ts Line 2870
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.