isSameXYZ MethodStatic
Boolean test for small xyz-distance within tolerance
.
- smallMetricDistance is used if tolerance is
undefined
. - Note that Point3d and Vector3d are both derived from XYZ, so this method tolerates mixed types.
isSameXYZ(dataA: XYZ, dataB: XYZ, tolerance: numberGeometry.smallMetricDistance): boolean
Parameter | Type | Description |
---|---|---|
dataA | XYZ | |
dataB | XYZ | |
tolerance | number |
Returns - boolean
Defined in
- Geometry.ts Line 406
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.