isAlmostEqualXAndY MethodStatic
Toleranced equality test using tolerance tolerance * ( 1 + abs(a.x) + abs(a.y) + abs(b.x) + abs(b.y) )
.
- smallAngleRadians is used if tolerance is
undefined
.
isAlmostEqualXAndY(a: Readonly<WritableXAndY>, b: Readonly<WritableXAndY>, tolerance: numberGeometry.smallAngleRadians): boolean
Parameter | Type | Description |
---|---|---|
a | Readonly<WritableXAndY> | |
b | Readonly<WritableXAndY> | |
tolerance | number |
Returns - boolean
Defined in
- Geometry.ts Line 543
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.