crossProductXYXY MethodStatic
2D cross product of vectors with the vectors presented as numbers.
- Sign of 2d cross product is positive <=> sweeping from first vector to second vector is ccw orientation.
- Sign of 2d cross product is negative <=> sweeping from first vector to second vector is clockwise orientation.
- 2d cross product is 0 <=> parallel/antiparallel vectors.
crossProductXYXY(ux: number, uy: number, vx: number, vy: number): number
Parameter | Type | Description |
---|---|---|
ux | number | |
uy | number | |
vx | number | |
vy | number |
Returns - number
Defined in
- Geometry.ts Line 798
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.