correctSmallMetricDistance MethodStatic
Correct a small distance.
correctSmallMetricDistance(distance: number, replacement: number0.0): number
@returns distance
if it is defined and has absolute value greater than smallMetricDistance;
otherwise returns replacement
Parameter | Type | Description |
---|---|---|
distance | number | metric value to test |
replacement | number | value to return if distance is too small. Default is zero. |
Returns - number
distance
if it is defined and has absolute value greater than smallMetricDistance;
otherwise returns replacement
Defined in
- Geometry.ts Line 312
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.