createFrameWithCCWPolygon MethodStatic
Try to create a frame whose xy plane is through points, with the points appearing CCW in the local frame.
- If 3 or more distinct points are present, the x axis is from the first point to the most distant, and y direction is toward the point most distant from that line.
createFrameWithCCWPolygon(points: Point3d[], result?: Transform): undefined | Transform
@returns localToWorld frame for the points, or undefined if insufficient data
Parameter | Type | Description |
---|---|---|
points | Point3d[] | array of points |
result | Transform | optional pre-allocated Transform to populate and return |
Returns - undefined | Transform
localToWorld frame for the points, or undefined if insufficient data
Defined in
- geometry3d/FrameBuilder.ts Line 327
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.