createFrameToDistantPoints MethodStatic

Try to create a frame whose xy plane is through points.

  • If 3 or more distinct points are present, the x axis is from the first point to the most distant, and y direction is toward the point most distant from that line.

createFrameToDistantPoints(points: Point3d[], result?: Transform): undefined | Transform

@returns localToWorld frame for the points, or undefined if insufficient data

Parameter Type Description
points Point3d[] array of points
result Transform optional pre-allocated Transform to populate and return

Returns - undefined | Transform

localToWorld frame for the points, or undefined if insufficient data

Defined in

Last Updated: 23 November, 2024