pointSetSingleClipStatus MethodStatic
Given an array of points, test for trivial containment conditions.
- ClipStatus.TrivialAccept if all points are in any one of the convexSet's.
- ClipStatus.ClipRequired if (in any single convexSet) there were points on both sides of any single plane.
- ClipStatus.TrivialReject if neither of those occurred.
pointSetSingleClipStatus(points: GrowableXYZArray, planeSet: UnionOfConvexClipPlaneSets, tolerance: number): ClipStatus
Parameter | Type | Description |
---|---|---|
points | GrowableXYZArray | |
planeSet | UnionOfConvexClipPlaneSets | |
tolerance | number |
Returns - ClipStatus
Defined in
- clipping/ClipUtils.ts Line 335
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.