loopsOfConvexClipPlaneIntersectionWithRange MethodStatic
Return a (possibly empty) array of geometry (Loops !!) which are facets of the intersection of the convex set intersecting a range.
- Return zero length array for (a) null range or (b) no intersections
loopsOfConvexClipPlaneIntersectionWithRange(allClippers: ClipPlane | ConvexClipPlaneSet | UnionOfConvexClipPlaneSets, range: Range3d, includeConvexSetFaces: booleantrue, includeRangeFaces: booleantrue, ignoreInvisiblePlanes: booleanfalse): GeometryQuery[]
Parameter | Type | Description |
---|---|---|
allClippers | ClipPlane | ConvexClipPlaneSet | UnionOfConvexClipPlaneSets | convex or union clipper |
range | Range3d | range to intersect |
includeConvexSetFaces | boolean | if false, do not compute facets originating as convex set planes. |
includeRangeFaces | boolean | if false, do not compute facets originating as range faces |
ignoreInvisiblePlanes | boolean | if true, do NOT compute a facet for convex set faces marked invisible. |
Returns - GeometryQuery[]
Defined in
- clipping/ClipUtils.ts Line 441
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.