doPolygonClipSequence MethodStatic
Pass polygon xyz
through a sequence of PolygonClip steps.
- At the outset,
xyz
is the (only) entry in a set of candidates. - For each clipper, each candidate is presented for appendPolygon to inside and outside parts.
- Each (in,out) result is distributed among (acceptedIn, acceptedOut, candidates) according to (inAction, outAction)
- At the end, all remaining candidates are distributed among (acceptedIn, acceptedOut, finalUnknown) according to finalAction
- Any clipper that does not have an appendPolygonClip method is skipped.
doPolygonClipSequence(xyz: IndexedXYZCollection, clippers: Clipper[], acceptedIn: GrowableXYZArray[], acceptedOut: GrowableXYZArray[], finalCandidates: GrowableXYZArray[], inAction: ClipStepAction, outAction: ClipStepAction, finalFragmentAction: ClipStepAction, arrayCache: ): void
Parameter | Type | Description |
---|---|---|
xyz | IndexedXYZCollection | |
clippers | Clipper[] | |
acceptedIn | GrowableXYZArray[] | |
acceptedOut | GrowableXYZArray[] | |
finalCandidates | GrowableXYZArray[] | |
inAction | ClipStepAction | |
outAction | ClipStepAction | |
finalFragmentAction | ClipStepAction | |
arrayCache |
Returns - void
Defined in
- clipping/ClipUtils.ts Line 986
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.