clipPolygonToClipShape MethodStatic
Clip a polygon down to regions defined by each shape of a ClipShape.
clipPolygonToClipShape(polygon: Point3d[], clipShape: ClipPrimitive): Point3d[][]
@returns An multidimensional array of points, where each array is the boundary of part of the remaining polygon.
Parameter | Type | Description |
---|---|---|
polygon | Point3d[] | |
clipShape | ClipPrimitive |
Returns - Point3d[][]
An multidimensional array of points, where each array is the boundary of part of the remaining polygon.
Defined in
- clipping/ClipUtils.ts Line 307
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.