clipAnyCurve MethodStatic
Compute and return portions of the input curve or region that are within the clipper.
clipAnyCurve(curve: AnyCurve, clipper: Clipper): AnyCurve[]
@returns array of clipped components of the input curve or region that lie inside the clipper
Parameter | Type | Description |
---|---|---|
curve | AnyCurve | input curve or region, unmodified |
clipper | Clipper | used to compute the clipped components |
Returns - AnyCurve[]
array of clipped components of the input curve or region that lie inside the clipper
Defined in
- clipping/ClipUtils.ts Line 287
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.