announceLoopsOfConvexClipPlaneSetIntersectRange MethodStatic
Emit point loops for intersection of a convex set with a range.
- return zero length array for (a) null range or (b) no intersections
announceLoopsOfConvexClipPlaneSetIntersectRange(convexSet: ClipPlane | ConvexClipPlaneSet, range: Range3d, loopFunction: (loopPoints: GrowableXYZArray) => void, includeConvexSetFaces: booleantrue, includeRangeFaces: booleantrue, ignoreInvisiblePlanes: booleanfalse): void
Parameter | Type | Description |
---|---|---|
convexSet | ClipPlane | ConvexClipPlaneSet | |
range | Range3d | range to intersect |
loopFunction | (loopPoints: GrowableXYZArray) => void | |
includeConvexSetFaces | boolean | if false, do not compute facets originating as convex set planes. |
includeRangeFaces | boolean | if false, do not compute facets originating as range faces |
ignoreInvisiblePlanes | boolean | if true, do NOT compute a facet for convex set faces marked invisible. |
Returns - void
Defined in
- clipping/ClipUtils.ts Line 378
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.