getBoundedSegmentSimpleIntersection Method
Compute intersection of (unbounded) segment with the plane.
- If the ends are on the same side of the plane, return undefined.
- If the intersection is an endpoint or interior to the segment return the fraction.
- If both ends are on, return undefined.
getBoundedSegmentSimpleIntersection(pointA: Point3d, pointB: Point3d): undefined | number
Parameter | Type | Description |
---|---|---|
pointA | Point3d | |
pointB | Point3d |
Returns - undefined | number
Defined in
- clipping/ClipPlane.ts Line 448
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.