radiansToSignedPeriodicFractionStartEnd MethodStatic

Return the fractionalized position of the given angle (as radians) computed with consideration of 2PI period and with consideration of angle sweep direction (CW or CCW).

  • the start angle is at fraction 0
  • the end angle is at fraction 1
  • interior angles are between 0 and 1
  • negative fraction for angles "before" the start angle
  • fraction larger than one for angles "after" the end angle
  • allows period shift

radiansToSignedPeriodicFractionStartEnd(radians: number, radians0: number, radians1: number, zeroSweepDefault: number0.0): number

@returns fraction, or zeroSweepDefault if the sweep is empty.

Parameter Type Description
radians number input angle (in radians)
radians0 number start angle of sweep (in radians)
radians1 number end angle of sweep (in radians)
zeroSweepDefault number return value when the sweep is empty (default 0)

Returns - number

fraction, or zeroSweepDefault if the sweep is empty.

Defined in

Last Updated: 21 November, 2024