radiansToSignedFractionStartEnd MethodStatic
Return the fractionalized position of the given radian angle with respect to the sweep.
- The start angle returns fraction 0
- The end angle returns fraction 1
- Interior angles (and their multiples of 2PI) return fractions in [0,1].
- Exterior angles return fractions outside [0,1] according to
toNegativeFraction
.
radiansToSignedFractionStartEnd(radians: number, radians0: number, radians1: number, toNegativeFraction: booleanfalse, zeroSweepDefault: number0.0): number
@returns fraction, or zeroSweepDefault
if the sweep is empty
Parameter | Type | Description |
---|---|---|
radians | number | input angle (in radians) |
radians0 | number | start angle of sweep (in radians) |
radians1 | number | end angle of sweep (in radians) |
toNegativeFraction | boolean | convert an exterior angle to a negative number (true), or to a number greater than one (false, default). If false, this is just radiansToPositivePeriodicFractionStartEnd. |
zeroSweepDefault | number | return value when the sweep is empty (default 0). |
Returns - number
fraction, or zeroSweepDefault
if the sweep is empty
Defined in
- geometry3d/AngleSweep.ts Line 433
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.