radiansToPositivePeriodicFractionStartEnd MethodStatic
Return the fractionalized position of the given angle (as radians), computed with consideration of 2PI period.
- consider radians0 as
start
angle of the sweep and radians1 asend
angle of the sweep - the start angle is at fraction 0
- the end angle is at fraction 1
- interior angles are between 0 and 1
- all exterior angles are at fractions greater than 1
- allows period shift
radiansToPositivePeriodicFractionStartEnd(radians: number, radians0: number, radians1: number, zeroSweepDefault: number0.0): number
@returns nonnegative fraction, or zeroSweepDefault
if the sweep is empty.
Returns - number
nonnegative fraction, or zeroSweepDefault
if the sweep is empty.
Defined in
- geometry3d/AngleSweep.ts Line 298
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.