radiansToPositivePeriodicFraction Method

Return the fractionalized position of the given angle (as radians), computed with consideration of 2PI period.

  • the start angle is at fraction 0
  • the end angle is at fraction 1
  • interior angles are between 0 and 1
  • all exterior angles are at fractions greater than 1
  • allows period shift

radiansToPositivePeriodicFraction(radians: number, zeroSweepDefault: number0.0): number

@returns nonnegative fraction, or zeroSweepDefault if the sweep is empty.

Parameter Type Description
radians number input angle (in radians)
zeroSweepDefault number return value when this sweep is empty (default 0)

Returns - number

nonnegative fraction, or zeroSweepDefault if the sweep is empty.

Defined in

Last Updated: 21 November, 2024