isAlmostEqualAllowPeriodShift Method
Test if two angle sweeps match within the given tolerance.
- Period shifts are allowed, but orientations must be the same.
isAlmostEqualAllowPeriodShift(other: AngleSweep, radianTol: numberGeometry.smallAngleRadians): boolean
Parameter | Type | Description |
---|---|---|
other | AngleSweep | sweep to compare to this instance |
radianTol | number | optional radian tolerance, default value Geometry.smallAngleRadians |
Returns - boolean
Defined in
- geometry3d/AngleSweep.ts Line 537
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.