fractionToSignedPeriodicFractionStartEnd MethodStatic

Convert a sweep fraction to the equivalent period-shifted fraction inside the sweep, or within one period of zero on the desired side.

fractionToSignedPeriodicFractionStartEnd(fraction: number, radians0: number, radians1: number, toNegativeFraction: boolean): number

@returns period-shifted fraction. If fraction is already in [0,1], or the sweep is empty, then fraction is returned unchanged.

Parameter Type Description
fraction number fraction of the sweep.
radians0 number start angle of sweep (in radians).
radians1 number end angle of sweep (in radians).
toNegativeFraction boolean return an exterior fraction period-shifted to within one period of the start (true) or
end (false) of the sweep.

Returns - number

period-shifted fraction. If fraction is already in [0,1], or the sweep is empty, then fraction is returned unchanged.

Defined in

Last Updated: 21 November, 2024